<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<meta charset="utf-8" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-26466179-8"></script>
<script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments)};gtag("js", new Date());gtag("config", "UA-26466179-8", {"groups":"default","anonymize_ip":true,"allow_ad_personalization_signals":false});</script>
<link rel="canonical" href="https://www.tribune-georgian.com/regional/ceo-florida-ports-council-misled-ohpa-about-combining-positions" />
<meta name="description" content="Chris Ragucci, CEO of Worldwide Terminals Fernandina, which operates the Port of Fernandina, also acts as port director since Laura DiBella left the job last year. Whether Ragucci can wear both those hats has been questioned, but Ragucci says the matter is moot, as complaints made to Ocean Highway..." />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="text/javascript">
// Initialize the google variables.
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
// Add a place to store the slot name variable.
googletag.slots = googletag.slots || {};
(function() {
  var useSSL = "https:" == document.location.protocol;
  var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
  document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgiansidebarnetwork2"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgiansidebarnetwork2", [300, 250], "js-dfp-tag-cni_tribunegeorgiansidebarnetwork2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianpromo"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianpromo", [300, 100], "js-dfp-tag-cni_tribunegeorgianpromo")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianskyscraper"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianskyscraper", [300, 600], "js-dfp-tag-cni_tribunegeorgianskyscraper")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgiansidebar3"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgiansidebar3", [300, 250], "js-dfp-tag-cni_tribunegeorgiansidebar3")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgiansidebar2"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgiansidebar2", [300, 250], "js-dfp-tag-cni_tribunegeorgiansidebar2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianweather"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianweather", [300, 100], "js-dfp-tag-cni_tribunegeorgianweather")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgiansidebarnetwork1"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgiansidebarnetwork1", [300, 250], "js-dfp-tag-cni_tribunegeorgiansidebarnetwork1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgiansidebar1"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgiansidebar1", [300, 250], "js-dfp-tag-cni_tribunegeorgiansidebar1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianpromotop"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianpromotop", [300, 100], "js-dfp-tag-cni_tribunegeorgianpromotop")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianmarketplace"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianmarketplace", [300, 100], "js-dfp-tag-cni_tribunegeorgianmarketplace")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianfooter1"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianfooter1", [728, 90], "js-dfp-tag-cni_tribunegeorgianfooter1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianfooter"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianfooter", [728, 90], "js-dfp-tag-cni_tribunegeorgianfooter")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianmidhome2"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianmidhome2", [300, 250], "js-dfp-tag-cni_tribunegeorgianmidhome2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianmidhome"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianmidhome", [300, 250], "js-dfp-tag-cni_tribunegeorgianmidhome")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianbanner"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianbanner", [468, 60], "js-dfp-tag-cni_tribunegeorgianbanner")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianmobile1"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianmobile1", [320, 50], "js-dfp-tag-cni_tribunegeorgianmobile1")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_tribunegeorgianleaderboard"] = googletag.defineSlot("//116205717/CNI-Tribunegeorgianleaderboard", [[728, 90], [300, 250]], "js-dfp-tag-cni_tribunegeorgianleaderboard")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
      googletag.pubads().enableAsyncRendering();
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
      });
googletag.enableServices();
</script>
<link rel="shortcut icon" href="/sites/tribune-georgian.etypegoogle7.com/files/tribfavi.jpg" type="image/jpeg" />
<link rel="revision" href="https://www.tribune-georgian.com/regional/ceo-florida-ports-council-misled-ohpa-about-combining-positions" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>

<title>CEO: Florida Ports Council misled OHPA about combining positions | Tribune &amp; Georgian, St. Marys, Georgia</title>
<link rel="stylesheet" media="all" href="/sites/tribune-georgian.etypegoogle7.com/files/css/css__4mJWn3VlDWRtAg_3sf1I9KSxaIhhh5EPyUtNCmLew0.css" />
<link rel="stylesheet" media="all" href="/sites/tribune-georgian.etypegoogle7.com/files/css/css_Us6lhXL_RZp38Sm3uTIWVZC4poYYSReQO9IRjJEUEcs.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Petrona" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Lato" />


<!--[if lte IE 8]>
<script src="/sites/tribune-georgian.etypegoogle7.com/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body class="path-node page-node-type-article tribune-georgian">
<a href="#main-content" class="visually-hidden focusable skip-link">
    Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    
<div class="layout-container">
  <div class="container is-widescreen">
    
    <header role="banner" class="columns">
        <div class="region region-header-left column">
    <div id="block-tiemposcni-date" class="block block-etype block-date-block">
  
    
      
<p class="is-size-7">November 20, 2020</p>
<div><a role="button" class="navbar-burger is-hidden-desktop" aria-label="menu" aria-expanded="false"><i class="fas fa-bars"></i></a></div>
    
    <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
  </div>
<div id="block-extendedsearch" class="block block-block-content block-block-content19db4b1e-4212-4bb2-838b-bd6bd2325075">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><a href="https://tribune-georgian.newsbank.com/">Extended Search</a></p></div>
      
  </div>

  </div>

        <div class="region region-header-center column">
    <div id="block-tiemposcni-branding" class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/tribune-georgian.etypegoogle7.com/files/Header-Egret.png" alt="Tribune &amp; Georgian, St. Marys, Georgia Home" />
    </a>
  </div>

  </div>

        <div class="region region-header-right column">
      
        <div class="user-menu navbar-menu is-active is-shadowless is-hidden-touch">
            <a href="https://etypeservices.com/ReadTheEdition.aspx?Username=maileastshore&amp;Pub=3278&amp;PType=SCCGS3278XXX1984I" target="_blank" id="etype_login_cni_e_edition" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">E-edition</a>
            <a href="https://www.etypeservices.com/Subscriber/SignIn.aspx?IssueID=213548&amp;ReturnUrl=https%3A//www.etypeservices.com/Subscriber/ReSubscribe.aspx%3FPubID%3D3278" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Renew</a>
            <a href="/index.php/etype-login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="etype-login">Log In</a>
            <a href="/index.php/user/login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="user/login">Log in</a>
            <a href="https://etypeservices.com/Tribune-GeorgianID594/default.aspx?PubID=3278" target="_blank" id="etype_login_cni_subscribe" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Subscribe</a>
        </div>
  





  </div>

    </header>

    
      <div class="region region-navigation columns">
      <nav role="navigation" id="main-nav" aria-label="user navigation" class="column">
    <div class="navbar">
                <div class="navbar-start is-really-invisible columns">
            <div class="column">
                                <a role="button" class="navbar-burger is-active" aria-label="menu" aria-expanded="false"><i class="fas fa-times"></i></a>
                                <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
                <div id="mobile-nav">
                                                                <a href="/index.php/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                    <a href="https://www.etypeservices.com/Tribune-GeorgianID594/" class="navbar-item">E-Edition</a>
                                                                                                        <a href="/index.php/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                            
                                                                    <a href="/index.php/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                    <a href="/index.php/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                    <a href="/index.php/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                    <a href="/index.php/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                    <a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1//Magazine112191/Full/index.aspx?II=112191" class="navbar-item">Classified</a>
                                                                                                        <a href="https://classadz.vdata.com/CommunityNewspapersFernandinaBeach/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                            
                                                                    <a href="https://www.etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine112193/Full/index.aspx?II=112193" class="navbar-item">Legals</a>
                                                                    <a href="/index.php/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                                                                                                        <a href="/index.php/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                    <a href="/index.php/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                    <a href="/index.php/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                            
                                                                    <a href="/index.php/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                                                        <a href="https://nearme.tribune-georgian.com/" class="navbar-item">Marketplace</a>
                                            
                                                                    <a href="http://www.etypeservices.com/Tribune-GeorgianID594/default.aspx?PubID=3278" class="navbar-item">Subscribe</a>
                                                                                </div>
            </div>
            <div class="column">
                <div class="block block-system block-system-branding-block">
  
    
        <a href="/index.php/" title="Home" rel="home" class="site-logo">
      <img src="/sites/tribune-georgian.etypegoogle7.com/files/Header-Egret.png" alt=" Home" />
    </a>
  </div>

            </div>
            <div class="column">&nbsp;</div>
        </div>
                <div id="main-navbar-menu" class="navbar-menu has-text-weight-semibold">
                                                                                                                                                                <a href="/index.php/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="https://www.etypeservices.com/Tribune-GeorgianID594/" class="navbar-item">E-Edition</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/index.php/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/index.php/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                                                                                                            <a href="/index.php/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                                                                                                            <a href="/index.php/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                                                                                                            <a href="/index.php/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1//Magazine112191/Full/index.aspx?II=112191" class="navbar-item">Classified</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://classadz.vdata.com/CommunityNewspapersFernandinaBeach/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="https://www.etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine112193/Full/index.aspx?II=112193" class="navbar-item">Legals</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/index.php/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/index.php/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                                                                                                                            <a href="/index.php/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                                                                                                                            <a href="/index.php/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/index.php/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://nearme.tribune-georgian.com/" class="navbar-item">Marketplace</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="http://www.etypeservices.com/Tribune-GeorgianID594/default.aspx?PubID=3278" class="navbar-item">Subscribe</a>
                                                                                                    
                    </div>
                <div class="navbar-end">
              <a href="https://www.facebook.com/tribuneandgeorgian/" class="has-text-grey-dark" target="_blank" aria-label="Facebook"><i class="fab fa-facebook is-size-3"></i><span class="sr-only">facebook</span></a>

        </div>
    </div>
</nav>




  </div>

    
      <div class="region region-leaderboard">
    <div id="block-dfptagcnitribunegeorgianleaderboard" class="block block-dfp block-dfp-ad36b48b3e-9fc0-4525-b182-b16af2d93d24">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianleaderboard">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianleaderboard');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianmobile1" class="block block-dfp block-dfp-addb4035fe-a07b-424d-8bbf-1b184ebb8278">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianmobile1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianmobile1');
        });
    </script>
</div>

  </div>

  </div>

      <div class="region region-top-content">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>


    <main role="main" class="columns">
      <a id="main-content" tabindex="-1"></a>      <div class="main-content-inner column">
                    <div class="region region-content">
    <div id="block-pagetitle" class="block block-core block-page-title-block">
  
    
      
  <h1 class="title"><span property="schema:name" class="field field--name-title field--type-string field--label-hidden">CEO: Florida Ports Council misled OHPA about combining positions</span>
</h1>


  </div>
<div id="block-tiemposcni-content" class="block block-system block-system-main-block">
  
    
      

<article data-history-node-id="2480" role="article" about="/regional/ceo-florida-ports-council-misled-ohpa-about-combining-positions" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-full regional">

  <div id="google_translate_element"></div>

  
      <span property="schema:name" content="CEO: Florida Ports Council misled OHPA about combining positions" class="rdf-meta hidden"></span>


      <footer class="node__meta">
      <article typeof="schema:Person" about="/user/16" class="profile">
  </article>

      <div class="node__submitted">
        <span id="author_id">By </span><span rel="schema:author" class="field field--name-uid field--type-entity-reference field--label-hidden"><a title="View user profile." href="/user/16" lang="" about="/user/16" typeof="schema:Person" property="schema:name" datatype="">News Staff</a></span>
 on Wednesday, November 18, 2020
          <span property="schema:dateCreated" content="2020-11-18T14:13:00+00:00" class="rdf-meta hidden"></span>

      </div>
    </footer>
  
  <div class="node__content">
                            
  <div class="clearfix text-formatted field field--name-field-subhead field--type-text-long field--label-visually_hidden">
    <div class="field__label visually-hidden">Subhead</div>
              <div class="field__item"><p>Chris Ragucci, CEO of Worldwide Terminals Fernandina, which operates the Port of Fernandina, also acts as port director since Laura DiBella left the job last year. Whether Ragucci can wear both those hats has been questioned, but Ragucci says the matter is moot, as complaints made to Ocean Highway...</p></div>
          </div>

                                              <div class="image-container">
<div id="flexslider-1" class="flexslider optionset-default imagestyle-flexslider-full">
 
<ul class="slides">
    
<li>
      <img property="schema:image" src="/sites/tribune-georgian.etypegoogle7.com/files/styles/flexslider_full/public/A1%2520JR%2520OHPA%2520tug%2520-%2520800x500.jpg?itok=MkYvOTMn" width="800" height="500" alt="The Ocean Highway and Port Authority is working to obtain a $1 million grant from the Maritime Administration to purchase the Ft. Clinch, a tug boat that is currently operating out of the Port of Fernandina. The port authority would then lease the boat to Worldwide Terminals Fernandina, the current operator of the port. Worldwide CEO Chris Ragucci said the company would use the tug’s current crew to operate the vessel. WORLDWIDE TERMINALS FERNANDINA" typeof="foaf:Image" class="image-style-flexslider-full" />



            <div class="flex-caption">The Ocean Highway and Port Authority is working to obtain a $1 million grant from the Maritime Administration to purchase the Ft. Clinch, a tug boat that is currently operating out of the Port of Fernandina. The port authority would then lease the boat to Worldwide Terminals Fernandina, the current operator of the port. Worldwide CEO Chris Ragucci said the company would use the tug’s current crew to operate the vessel. WORLDWIDE TERMINALS FERNANDINA</div>
    </li>
</ul>
</div>
</div>
                        <div class="field">Chris Ragucci, CEO of Worldwide Terminals Fernandina, which operates the Port of Fernandina, also acts as port director since Laura DiBella left the job last year. Whether Ragucci can wear both those…</div>
            <div class="premium_message is-sans-serif"><p>Premium Content is available to subscribers only. Please login&nbsp;<strong><a href="/etype-login">here</a></strong>&nbsp;to access&nbsp;content or go<strong>&nbsp;<a href="http://www.etypeservices.com/Tribune-GeorgianID594/default.aspx?PubID=3278">here</a></strong>&nbsp;to purchase a subscription.</p>
</div>
          
                    </div>
</article>

  </div>
<div id="block-dfptagcnitribunegeorgianbanner" class="block block-dfp block-dfp-ad3b484fd5-39b2-48fb-b0ce-c63664280701">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianbanner">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianbanner');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianmidhome" class="block block-dfp block-dfp-ad71fcd904-4094-402a-982c-acd31b7d1607">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianmidhome">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianmidhome');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianmidhome2" class="block block-dfp block-dfp-add5f8543a-8bf1-4bd5-aefa-9c6c77daabf7">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianmidhome2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianmidhome2');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianfooter" class="block block-dfp block-dfp-ad8129f14c-2425-4254-b589-abe8c392b185">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianfooter">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianfooter');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianfooter1" class="block block-dfp block-dfp-ad4e5cff14-3d6c-49df-9858-92fa385d236e">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianfooter1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianfooter1');
        });
    </script>
</div>

  </div>

  </div>

        
        
              </div>

                <aside class="region region-sidebar column layout-sidebar"  role="complementary">
    <div id="block-dfptagcnitribunegeorgianmarketplace" class="block block-dfp block-dfp-addb288c4a-ef41-4741-b4df-a0535fbad938">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianmarketplace">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianmarketplace');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianpromotop" class="block block-dfp block-dfp-ad4c6b84a9-5adb-4c12-91f2-26406f308084">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianpromotop">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianpromotop');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgiansidebar1" class="block block-dfp block-dfp-ad1241ae80-ea23-4d43-a134-bf6a7ca15c81">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgiansidebar1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgiansidebar1');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-etypeeedition" class="block block-etype block-etype-block">
  
    
      <div class="e-edition"><div><a href="https://etypeservices.com/Tribune-GeorgianID594" target="_blank" aria-label="Tribune &amp; Georgian, St. Marys, Georgia e-Edition"><img src="https://etypeservices.com/LandingPageImages/Tribune-Georgian/currentpg1.jpg" alt="Tribune &amp; Georgian, St. Marys, Georgia e-Edition"></a></div>
<p><a href="https://etypeservices.com/Tribune-GeorgianID594" target="_blank" aria-label="Tribune &amp; Georgian, St. Marys, Georgia e-Edition">Read Tribune &amp; Georgian, St. Marys, Georgia</a></p></div>

  </div>
<div id="block-weatherwidget-2" class="block block-etype block-weatherwidget-block weatherwidget">
      <iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=117998" frameborder="0" scrolling="no" title="Weather Widget"></iframe>
  </div>
<div id="block-dfptagcnitribunegeorgiansidebarnetwork1" class="block block-dfp block-dfp-ad398dc2d6-246b-4759-b9c4-55f4023b276e">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgiansidebarnetwork1">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgiansidebarnetwork1');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianweather" class="block block-dfp block-dfp-ad6c1de512-16d3-484c-b908-11e0a6675e67">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianweather">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianweather');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgiansidebar2" class="block block-dfp block-dfp-ad46950c1a-b827-4d7e-95fd-67a28d4faaa1">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgiansidebar2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgiansidebar2');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-popularcontent" role="navigation" class="block block-statistics block-statistics-popular-block">
  
      <h3 class="section-tag-heading">Popular content</h3>
    
      <div class="item-list"><h3>Today's:</h3><ul><li><a href="/local/kingsland-hosts-38th-annual-catfish-festival" hreflang="en">Kingsland hosts 38th annual Catfish Festival</a></li><li><a href="/local/election-office-finishes-recount-woodbine" hreflang="en">Election office finishes recount in Woodbine</a></li><li><a href="/local/gbi-seeks-dna-evidence-1985-murder-case" hreflang="en">GBI seeks DNA evidence in 1985 murder case</a></li></ul></div><br /><div class="item-list"><h3>All time:</h3><ul><li><a href="/regional/latest-covid-19-numbers-nassau-county" hreflang="en">Latest COVID-19 numbers for Nassau County</a></li><li><a href="/obituaries/glover-0" hreflang="en">Glover</a></li><li><a href="/regional/covid-19-numbers-nassau-county-2" hreflang="en">The COVID-19 numbers for Nassau County</a></li></ul></div><br /><div class="item-list"><h3>Last viewed:</h3><ul><li><a href="/local/kingsland-hosts-38th-annual-catfish-festival" hreflang="en">Kingsland hosts 38th annual Catfish Festival</a></li><li><a href="/obituaries/teston" hreflang="en">Teston</a></li><li><a href="/local/election-office-finishes-recount-woodbine" hreflang="en">Election office finishes recount in Woodbine</a></li></ul></div><br />
  </div>
<div id="block-dfptagcnitribunegeorgiansidebar3" class="block block-dfp block-dfp-ad30ebaa04-3332-41ce-a90c-122591b1c47a">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgiansidebar3">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgiansidebar3');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianskyscraper" class="block block-dfp block-dfp-adac62b2fc-997a-4519-a3ae-c40868f69533">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianskyscraper">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianskyscraper');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgianpromo" class="block block-dfp block-dfp-adb047d5bf-480a-46c7-8841-be2f2f70dc8e">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgianpromo">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgianpromo');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnitribunegeorgiansidebarnetwork2" class="block block-dfp block-dfp-ad01927b80-3c0d-4717-ae81-485e637c9e0a">
  
    
      <div id="js-dfp-tag-cni_tribunegeorgiansidebarnetwork2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_tribunegeorgiansidebarnetwork2');
        });
    </script>
</div>

  </div>

  </aside>

      
    </main>

    <footer role="contentinfo" class="columns border-top-light">
                <div class="region region-footer-left column">
    <div id="block-tiemposcni-contactinformation" class="block block-block-content block-block-contentbb8e208a-8245-4087-b0c0-a5b20e5a2929">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><strong>TRIBUNE &amp; GEORGIAN</strong></p>

<p><strong>Mailing Address:</strong><br />
P.O. Box 6960<br />
St. Marys, GA 31558</p>

<p><strong>Phone:</strong> 912-882-4927<br />
<strong>Fax:</strong> 912-882-6519</p></div>
      
  </div>

  </div>

                      <div class="region region-footer-center column">
    <div id="block-tiemposcni-copyrightnotice" class="block block-etype block-copyright-block">
  
    
      <p class="has-text-centered">&copy;&nbsp;2020&nbsp;Tribune & Georgian, St. Marys, Georgia</p>
  </div>

  </div>

                      <div class="region region-footer-right column">
      
    <ul class="menu footer-menu is-pulled-right">
          <li class="menu-item">
      <a href="https://nearme.tribune-georgian.com/" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Marketplace</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/contact" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="contact">Contact</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/webforms" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="webforms">Webforms</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/about" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/969">About Us</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/archives" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/973">Archive</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/links" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1497">Links</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/etype-login" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="etype-login">Login</a>
    </li>
          <li class="menu-item">
      <a href="https://www.etypeservices.com/Privacy.aspx" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Privacy Policy</a>
    </li>
          <li class="menu-item">
      <a href="/index.php/ada-compliance" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="ada-compliance">Accessibility Policy</a>
    </li>
  </ul>
  





  </div>

          </footer>

    <section id="coupons" class="columns">
          </section>

  </div>
</div>
  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/2480","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"google_analytics":{"account":"UA-26466179-8","trackOutbound":true,"trackMailto":true,"trackDownload":true,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"statistics":{"data":{"nid":"2480"},"url":"\/core\/modules\/statistics\/statistics.php"},"flexslider":{"optionsets":{"default":{"animation":"fade","animationSpeed":600,"direction":"horizontal","slideshow":true,"easing":"swing","smoothHeight":false,"reverse":false,"slideshowSpeed":7000,"animationLoop":true,"randomize":false,"startAt":0,"itemWidth":0,"itemMargin":0,"minItems":0,"maxItems":0,"move":0,"directionNav":true,"controlNav":true,"thumbCaptions":false,"thumbCaptionsBoth":false,"keyboard":true,"multipleKeyboard":false,"mousewheel":false,"touch":true,"prevText":"Previous","nextText":"Next","namespace":"flex-","selector":".slides \u003E li","sync":"","asNavFor":"","initDelay":0,"useCSS":true,"video":false,"pausePlay":false,"pauseText":"Pause","playText":"Play","pauseOnAction":true,"pauseOnHover":false,"controlsContainer":".flex-control-nav-container","manualControls":""}},"instances":{"flexslider-1":"default"}},"user":{"uid":0,"permissionsHash":"a9bb809a72593f7676c735244b1ad31eea510cca2f0f7ee6320c17079314de37"}}</script>
<script src="/sites/tribune-georgian.etypegoogle7.com/files/js/js_aRVJ3MdDVYsxtzIyliTzcm576TFmee9hAxhtWFHgGbw.js"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/sites/tribune-georgian.etypegoogle7.com/files/js/js_Q3EyUmEB-CngSfyvx76cTqZFq7lnDrnVmtqUd425mgw.js"></script>
<script src="//use.fontawesome.com/releases/v5.8.1/js/all.js" defer></script>
<script src="/sites/tribune-georgian.etypegoogle7.com/files/js/js_AoPW-OBXHiQ19nF9NoQjiBDV3aF-Vygd-MXD6RosbSM.js"></script>


</body>
</html>
